Changing Default Language of Chrome's Omnibar Google Search

Moderator: Mick

Changing Default Language of Chrome's Omnibar Google Search

Postby SlowRain » 09 Jun 2012, 18:07

How do you change the default language for Google Search in Chrome's omnibox? It had been English for me for a while, but then it went Chinese yesterday. Whenever I type a search, it filters it through Google Taiwan. I've tried a couple of remedies posted on other websites, but I think those must be for older versions of Chrome because nothing's working for me. Is anyone else having this problem?
Forumosan avatar
SlowRain
Newspaper Copyeditor (bàoshè biānjí)
Newspaper Copyeditor (bàoshè biānjí)
 
Posts: 486
ORIGINAL POSTER
Joined: 17 Jul 2009, 17:39
Location: Taichung
12 Recommends(s)
5 Recognized(s)

6000

Re: Changing Default Language of Chrome's Omnibar Google Search

Postby cto » 14 Jun 2012, 08:54

How to change the default search engine can be found here:
http://support.google.com/chrome/bin/an ... swer=95653

Add this one:
http://www.google.com/search?q=%s

Then set it as the default.


You can also go to the English search page (or set it has your homepage). The address is:
http://www.google.com/ncr
cto
Ink Still Wet in Passport (shífēn xīnshǒu)
Ink Still Wet in Passport (shífēn xīnshǒu)
 
Posts: 23
Joined: 27 Apr 2011, 17:41

6000

Re: Changing Default Language of Chrome's Omnibar Google Search

Postby SlowRain » 15 Jun 2012, 10:33

Yeah, I've tried those and a couple others. They didn't work.

I find that if I log into my Google account at the start of each session, it resets everything to English. If I close my browser and open it again, everything is back to Chinese and I have to log into my Google account again. It's getting annoying.

EDIT: I may have found the solution. I unchecked the option to clear cookies when the browser closes. Funny, I never had this problem until a couple of days ago. :ponder:
Forumosan avatar
SlowRain
Newspaper Copyeditor (bàoshè biānjí)
Newspaper Copyeditor (bàoshè biānjí)
 
Posts: 486
ORIGINAL POSTER
Joined: 17 Jul 2009, 17:39
Location: Taichung
12 Recommends(s)
5 Recognized(s)

6000

Re: Changing Default Language of Chrome's Omnibar Google Search

Postby ceevee369 » 15 Jun 2012, 10:55

Some black magic might look at your IP address and route to there.
Look at your settings related to Regions - default country. Change to the US, cleanse once more our browser cache and try again.

Also your google account should have US or anything else as default.
I’m a dog shaped ashtray
I’m a shrugging moustache wearing a speedo tuxedo
I’m a movie with no plot, written in the back seat of a piss powered taxi
I’m an imperial armpit, sweating Chianti
I’m a toilet with no seat, flushing tradition down
I'm socialist lingerie
I'm diplomatic techno
I'm gay pastry and racist cappuccino
I’m an army on holiday in a guillotine museum
I’m a painting made of hair, on a nudist beach, eating McDonald's
I’m a novel far too long
I’m a sentimental song
I’m a yellow tooth waltzing with wrap around shades on

Who am I?
I am Europe
Forumosan avatar
ceevee369
Lost Winning Lotto Ticket (zhòngjiǎng cǎiquàn nòngdiū le)
Lost Winning Lotto Ticket (zhòngjiǎng cǎiquàn nòngdiū le)
 
Posts: 2947
Joined: 27 Feb 2005, 16:27
Location: Linkou Heights
47 Recommends(s)
27 Recognized(s)

6000

Re: Changing Default Language of Chrome's Omnibar Google Search

Postby SlowRain » 15 Jun 2012, 11:40

I just checked. My region was set to "United States".

I imagine Google made some changes to either Chrome or the way their site works a few days ago.
Forumosan avatar
SlowRain
Newspaper Copyeditor (bàoshè biānjí)
Newspaper Copyeditor (bàoshè biānjí)
 
Posts: 486
ORIGINAL POSTER
Joined: 17 Jul 2009, 17:39
Location: Taichung
12 Recommends(s)
5 Recognized(s)

6000





 

Return to Technology



Who is online

Forumosans browsing this forum: No Forumosans and 3 visitors

The best way to remember your wife's birthday is to forget it once -- E. JOSEPH COSSMAN